Treating warnings as errors because process.env.CI = true.

Si estamos trabajando con alguna herramienta de Integración continua puede que el compilador nos lance este error y no haga el build de nuestro proyecto:

Treating warnings as errors because process.env.CI = true.

Hay controversia sobre este tema (podéis buscar en Google más info al respecto), para ser breve e ir al grano como en todos los posts de este blog, la solución pasaría por añadir al build command «CI=false».

Con lo que, por ejemplo, si teníamos:

npm run build

Deberíamos modificarlo por:

CI=false npm run build

Y ya nos debería de compilar la app.


Tu opinión es importante para mi, ¿Te ha resultado útil este artículo?

¿Eres programador/a?

En Pulpo están buscando nuevos talentos, envíales un email a developers@pulpoapp.com.

2 Comments

kike

Hola Pedro!!

Muchas gracias, me alegro mucho si te ayudó a resolver el problemita.

Saludos!

Reply

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*