Error al instalar Angular /usr /local /lib /node_modules /@angular /cli /models /config /config.js

Hola, puede que al tratar de instalar angular tengáis un problema parecido a este:

$ ng new angular-tour-of-heroes
/usr/local/lib/node_modules/@angular/cli/models/config/config.js:17
    constructor(_configPath, schema, configJson, fallbacks = []) {
                                                           ^

SyntaxError: Unexpected token =
    at exports.runInThisContext (vm.js:53:16)
    at Module._compile (module.js:373:25)
    at Object.Module._extensions..js (module.js:404:10)
    at Module.load (module.js:343:32)
    at Function.Module._load (module.js:300:12)
    at Module.require (module.js:353:17)
    at require (internal/module.js:12:17)
    at Object. (/usr/local/lib/node_modules/@angular/cli/models/config.js:3:18)
    at Module._compile (module.js:397:26)
    at Object.Module._extensions..js (module.js:404:10)

Primero comprobad si tenéis instalado ng con:

$ ng version

Si aquí os vuelve a aparecer un error parecido probad a limpiar caché y reinstalar npm

npm cache clean -f
npm install -g n
n stable

Y ahora probad de nuevo.

si no tenéis node.js actualizado puede que os salte un error tipo:

npm ERR! code MODULE_NOT_FOUND
npm ERR! Cannot find module 'internal/util/types'

npm ERR! A complete log of this run can be found in:
npm ERR!     /Users/kike/.npm/_logs/2018-03-15T15_56_32_289Z-debug.log

Para ello, debéis actualizad node.js, para los usuarios de Mac, simplemente entrad a https://nodejs.org/ y descargad la última versión.

Volved a ejecutar la instalación (después de borrar la carpeta creada anteriormente) y a funcionar.

$ ng new angular-tour-of-heroes

Si?? No? Va??

Saludoss 🙂


Tu opinión es importante para mi, ¿Te ha resultado útil este artículo?

¿Eres programador/a?

En Pulpo están buscando nuevos talentos, envíales un email a developers@pulpoapp.com.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*